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overview:
Adobe After Effects is a motion graphics and compositing 
application. It excels at combining a variety of media formats 
in a timeline setting, where these media can be combined 
with text, shapes, and other graphics to produce an animated 
sequence.

The organizational structure of After Effects is based on 
compositions: sequences of media that can be exported as 
a movie file or nested within other compositions  and then 
exported as a movie file. Those compositions are stored in a 
project, which links back to all of the media files used in creating 
your compositions.

organizing assets:
Because an After Effects project links back to all of the assets 
referenced in a project, it is important to maintain a consistent 
file structure. Before beginning a project, you may want create 
folders that to contain the various elements in your project, 
including video, audio, vector graphics, and raster images, or 
only reference to files that you know will not be moved during 
the production of the project.

starting a new project:
When you first open After Effects, a splash-screen will pop up. 
On this screen, choose New Project. Or choose File > New > New 
Project.

organizing the project panel:
The project panel displays a list of all the assets used in the 
current project and gives you the ability to organize those assets. 
Compositions that you create will also be displayed in this list. 

To organize your assets in this panel, create new folders by 
pressing the folder icon at the bottom of the panel. A few 
folders you might want to create include Video, Audio, Photos, 
Graphics, and Compositions. Develop a structure that works well 
for your workflow.

 

adobe after effects
animated compositions, layering, masking, keyframing

Project panel 
Keep your assets organized within your project. 
Changes in the project panel will not affect the 
files on your system. Edits to footage in After 

Effects are non-destructive.

Keep your assets organized
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Composition (or Footage) Panel 
Active compositions or footage 

are displayed in this window. 
Some types of edits, like adding 

shapes and text or applying trans-
formations can be made directly 
in this panel. Multiple items can 

be open at the same time and are 
accessible as tabs at the top of 

this panel. 
Toolbar

Workspaces

Contextual Panels 
Different panels will open here 
as you utilize different tools or 
as you change the workspace 

mode. (This screenshot displays 
the “Standard” workspace.

Project Panel 
Displays all imported footage and 

compositions in the current project. 
Use this panel to organize your 

project. Changes made here do not 
affect the underlying file structure.

Composition Timeline 
Displays the timeline and layers 

for the open composition. The left 
side provides a list of the layers in 
the project (audio, video, shapes, 

etc.), and the right side shows 
you where and how that media 

appears in time. You will use 
this panel to make many edits, 

including keyframing. 

the after effects workspace:
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Adding text layers:
To add text to a composition select the Type tool (T) and click 
somewhere inside your composition. Type your text. The right 
panel will now allow you to make adjustments to the character 
and paragraph attributes.  

Adding shape layers:

Shape layers are vector-based elements, allowing them to be 
scaled up and down without losing sharpness. 

To create a shape layer, first make sure you do not have a layer 
selected by clicking in the gray area below your layers in the 
layer panel, or choose Edit > Deselect All (Shift+Command+A, 
Ctrl+Shift+A). Now use the pen tool (G) to create a closed 
polygon or a line. As soon as you start drawing, you will see that 
a new layer named “Shape Layer #” will be created to contain 
the shape you are drawing. 

Now that you have drawn a shape you can alter its stroke, fill, 
and other attributes in the tool ribbon or in the layer panel. To 
see the shape in its layer, press the arrow button to expand the 

Shape Layer, and then its Contents. 

masks:

Masks allow you to hide and reveal layers or portions of layers. 
They are created with the same tools as shape layers but are 
attached as a mask to a layer (not as a separate shape layer). 
Select the layer on which you want to create a mask. Choose the 
pen tool (G) and draw a shape around the area you want to mask 
out (remove). You will see that in the layer hierarchy, there will be 
a new tab called “Masks”. Expanding that tab, we can see all of 
the masks associated with a layer, and, expanding a single mask 
tab, we can alter that mask’s properties. Other alterations to the 
mask (feathering, inverting, etc.) can be made by going to Layer 
> Mask from the top menu bar.  

Adding a Text Layer  
Note that the new text has its own 
layer in the timeline/layer panel.

Adding Shape Layers 
Note that the shapes have their own 

layers in the timeline/layer panel.

Masking 
Draw irregular masks with the pen 

tool. Note that this mask is “inverted” 
(checkbox in the layer). 
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keyframing:

Keyframing allows you to change the property of an item 
over time. It is a method of setting the properties of an item 
at multiple points in time and the interpolation of that items 
qualities (position, color, scale, etc.) between those two times.

To keyframe the attributes of an object, expand a layer (click the 
arrow next to the layer name) and then expand the Transform 
tab. Let’s change the opacity of an object from 0% to 100%. 
To do this, click the stopwatch icon next to “Opacity”, enabling 
keyframing for that attribute. Move the playhead to the 
beginning of your composition (I). Change the opacity to 0% by 
click-dragging to the left or typing in “0”. We are telling this layer 
“At time 0:00:00:00, this layer is at 0% opacity”. 

Now, move the playhead to the end of your composition (O). 
Change the opacity to 100%. Play the composition from the 
beginning. Your layer should now fade in from 0% to 100% 
opacity over the course of the composition. 

You will also see that there are two diamond shaped icons where 
you set the opacity in the same row as opacity in the timeline. 
These are your actual keyframes, holding an attribute and a 
time. Try dragging the diamond at the end of the composition 
to somewhere near the middle. Play your composition again. 
Now the layer should be at 100% opacity at whatever point you 
moved the keyframe to.

You can add as many keyframes as you want to a layer, and they 
can be applied to any attribute that has a stopwatch icon next to 
it. Try making the scale, position, or rotation of an object change 
over the course of the composition.

0 seconds: 
circle is small, and 

in the top-left-hand 
corner of the 
composition

5 seconds: 
circle is larger, and 
in the lower-right-
hand corner of the 

composition

0–5 seconds: 
circle position and 

scale is interpolated at 
each frame between 0 

and 5 seconds.

Keyframing 
Here, the opactiy of the background photo has been 
keyframed so that it appears to fade in from black A 

black solid layer has been added below the image layer: 
Layer > New > Solid….
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Exporting a composition:
You can export your composition as a .MOV file from After 
Effects, but this file is going to be very large. To export as a 
compressed (yet still high quality) .MP4 file, you will need to 
download a separate application, the Adobe Media Encoder 
(included with a Creative Cloud license)1.

When you are ready to export a composition, choose:

 Composition > Add to Adobe Media Encoder Queue…  
(Ctrl+Option+M, Ctrl+Alt+M)

The Adobe Media Encoder will open if it is not already, and your 
composition will be added to the queue. Choose “.H264” under 
format if it is not already, and click on “.H264.” .H264 is the 
video format that will be used in our .MP4 file.

In the Export Settings panel, under Preset, you can select from 
a list of setting presets that are optimized for various output 
locations, such as Vimeo, YouTube, or a mobile device2. Once you 
have configured your settings, press “OK”. 

Under the “Output File” column, click the file path and choose 
where you want the exported file to be saved. Press “Save”.

When you are ready to export, press the green play button in 
the top right-hand corner, or simply press “Enter”. You will see 
the encoding process as a blue bar. Your file should now be in 
the location you specified. Check the file size and change your 
settings if necessary and re-export. 

packaging a project:
Perhaps your project is referencing files that are scattered across 
your system, you need to archive the project, or you want to 
send it to a collaborator. To pull all of those files into a single 
location, choose: 

File > Dependencies > Collect Files…

Press “Collect…” and then a location where you want the 
collected files to be copied to. This package will inherit the file 
structure that you built in your Project panel. 

1	 .MP4 and .MOV are both file containers. They are not the 
video file itself but contain a variety of files for the video, 
audio, captions (if they are included), and metadata. Our 
.MP4, for example, will hold a .H264 format video file and an 
ACC format audio file.

2	 These settings are tailored to work best with the codec 
particular to each location. A codec is a method for encoding 
and decoding a digital data stream (codec is a portmanteau 
of coder-decoder).

Export Settings Window 
Choose a preset or set your 

preferences manually on the right. 
A preview of your encoded file will 

appear on the left.

Adobe Media Encoder 
Files in the queue appear as a list 
on the right. Multiple files can be 

added to the list and then encoded 
en masse.

Packaging/Collect Files
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Footage stabilization:
After Effects includes a powerful tool for stabilizing shaky 
footage. We will look at the most basic operations1. 

Once you have added the shaky footage to a composition, select 
that footage layer and choose:

Effect > Distort > Warp Stabilizer VFX

The text “Analyzing in background (step 1 of 2)” will appear over 
your footage. In the first step, After Effects analyzes the footage 
to understand the camera motion. In the second step, it will 
stabilize the footage based on the parameters that you set in 
the effect controls. 

Under the Effect Controls, under “Result” choose either “Smooth 
Motion” or “No Motion”. Smooth Motion is for shots where you 
are intentionally moving the camera (e.g. you are riding a bicycle 
or you are standing still but panning across the scene). No 
Motion is for shots where you didn’t intend the camera to move 
at all (e.g. you were standing still holding the camera).

 “Smoothness” is essentially the amount of stabilization applied. 

“Framing” determines how the stabilized footage is rectified to 
fit the composition frame. Typically, I choose “Stabilize, Crop, 
Auto-scale,” meaning that the footage is stabilized, cropped so 
that we don’t see the wandering edges of the frame, and then 
resized to fit the composition frame. If the footage is very shaky, 
so much cropping will be done that the footage’s resolution will 
be noticeably lower (and you will not see as much of your scene).

Play around with these settings to achieve a desired result. With 
the effect applied, you can use this footage like any other layer.

1	 For more information, see: https://blogs.adobe.com/
creativecloud/warp-stabilizer-in-after-effects-cs5-5/?seg-
ment=dva

2: Stabilization

Stabilization options

1: Analysis

https://blogs.adobe.com/creativecloud/warp-stabilizer-in-after-effects-cs5-5/?segment=dva
https://blogs.adobe.com/creativecloud/warp-stabilizer-in-after-effects-cs5-5/?segment=dva
https://blogs.adobe.com/creativecloud/warp-stabilizer-in-after-effects-cs5-5/?segment=dva

